Announcement

Collapse
No announcement yet.

Accurate spedometer?

Collapse

Forum Thread First Post

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JeepGal
    replied
    VERY EASY install! remove the retaning bolt...take out the sender and gear, pull the old one off, push the new one one. Really. That easy. Make sure you line up the tooth numbers with the arrow on the housing.

    Tam
    Last edited by JeepGal; 03-22-04, 12:17 PM.

    Leave a comment:


  • carrizojim
    replied
    With 33's and 3.07's you will probably be considering getting gears... Remember the speedo drives off of the transfer case, so if you re-gear your diffs later, you'll probably have to change it back again, so save the speedo drive gear that you remove... Mine is off about 10mph on the freeway at 65 when I checked it with my GPS...

    Leave a comment:


  • sarah
    replied
    would my local jeep dealer be able to get it and install it, you think? If not where the heck would i get a speedo gear?
    Again see the other thread in the second post here ...

    You can get it at the dealership and I believe it's a fairly simple install, you can probably do it yourself to save some dough.

    Leave a comment:


  • AshenShugar00
    replied
    would my local jeep dealer be able to get it and install it, you think? If not where the heck would i get a speedo gear?

    Leave a comment:


  • PondScum
    replied
    Assuming you have the stock 3.07 gears you will need a 25 tooth speedo gear to get your speedometer accurate again on the 33's.

    It runs around $10-$20 depending on where you get it.

    Leave a comment:


  • sarah
    replied
    not sure if it's the same as a TJ, but you might be able to use some of the links in this thread.

    Leave a comment:


  • AshenShugar00
    started a topic Accurate spedometer?

    Accurate spedometer?

    Ok I just bought an 88 Jeep Wrangler, V6, 33 x 12.5 tires and some lift kit on it. And the speedometer is off. Im thinkgin because of the tires because its kindof right ( the speedometer, i mean) Does any one know how to fix this?
Working...
X