Announcement

Collapse
No announcement yet.

over heating!!!!

Collapse

Forum Thread First Post

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • denten
    replied
    i drove it around today and it seems to be working. i cleaned it all out so hopefully that helped. thx

    Leave a comment:


  • shortbus
    replied
    What kind of fan do you run, if it's electric, make sure it's working, also, check the thermostst.

    Leave a comment:


  • tjrubicon
    replied
    I may be wrong, but since you were running hot your t-stat was more than likely open leaving no pressure in the hoses. Check you radiator for mud. If you were going through watery mud, you may have clogged your radiator. It's happened to my brother before. If thats the case, hose your radiator until clear water starts coming out.

    I'm talking about the radiator itself, not flushing it. In other words spray water through the grill into the radiator and maybe from the engine compartment towards the the front to get mud build up washed out of the vents.

    Leave a comment:


  • denten
    started a topic over heating!!!!

    over heating!!!!

    I just took my jeep mudding, and when i stopped at a gas station to clean some things off, my overflow was bubbling and i was leaking fluids. Its never happened to me before but im not really sure whats wrong. I checked the hoses to see if their was fluid going through them but it was soft so no dice. I drove it home and it was still hot. Anyone know whats going on?
Working...
X